Zum Inhalt springen

Magenta Community

  • Ankündigungen

    • Ping Anrufe von +680   
      06/02/20

      Es sind vermehrt Anrufe mit der Vorwahl 00680 (Republik Palau) im Umlauf. Bitte hier auf keinen Fall zurückrufen und den Anruf ignorieren.  Für Interessierte: Palau auf Google Maps

      Weiterlesen...

Schon wieder ein Port-Forwarding-Problem Thread [Internet Flex Box B529s-23a]

Hallo, trotz ausführlichem Durchschauen ähnlicher Threads zum Thema habe ich es leider nicht geschafft das Problem selbstständig zu lösen, weshalb ich ein neues Topic für meine spezifische Problematik aufmachen muss. Ich bitte im Voraus um Verständnis :(

 

Ich versuche momentan einen privaten Server für ein Spiel einzurichten, welches den Port 22023 freigeschaltet braucht - gerade an der Port-Weiterleitung scheitert das Vorhaben: zwar zeigen die Router-Einstellungen meiner Internet Flex Box [Huawei B529s-23a] an, dass die Weiterleitung sowohl über UDP als auch TCP eingeschaltet ist, aber laut https://www.yougetsignal.com/ ist der Port weiterhin nicht zugänglich. (Ich teste von meinem LTE-vernetztem Handy.)

 

Die Profiländerung auf Business APN hat mir zwar zur fixen IP-Adresse verholfen (entspricht 78.***.***.**.***; habs in den Router-Einstellungen kontrolliert), brachte aber sonst keine Wirkung. Neustart / Strom ausstecken von Router und Computer führte ebenfalls zu keiner Änderung.

 

Muss vielleicht einfach drüber schlafen, wäre aber echt dankbar, wenn mir jemand weiterhelfen könnte.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

41 Antworten auf diese Frage

Recommended Posts

Hello,

kannst du vielleicht mal deine Settings der Portweiterleitung hier posten?

 

Ich nehme an du hast nur die Flex Box und dahiner nichts, richtig?

 

Liebe Grüße

Mario

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Gerade eben schrieb MarioM:

Hello,

kannst du vielleicht mal deine Settings der Portweiterleitung hier posten?

 

Ich nehme an du hast nur die Flex Box und dahiner nichts, richtig?

 

Liebe Grüße

Mario

Hallo, vielen Dank für die Antwort; anbei die Daten

portforwarding.PNG.21e7cb2399d5b5a6af676a2a5129243b.PNG

Richtig, betreibe ausschließlich die Flex Box.

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hmm, sieht soweit mal gut aus - der Server läuft auch dahinter schon? Bevor nämlich da nichts läuft wird der Port auch nicht offen sein.

Also ich nehme an im internen Netzwerk kommst du ohne Probleme hin?

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 9 Minuten schrieb MarioM:

Hmm, sieht soweit mal gut aus - der Server läuft auch dahinter schon? Bevor nämlich da nichts läuft wird der Port auch nicht offen sein.

Also ich nehme an im internen Netzwerk kommst du ohne Probleme hin?

Der Server läuft, intern kann ich mich auch nicht verbinden - kriege einen "connection timed out"-artigen Fehler

 

edit:/ am Firewall liegts nicht, die entsprechenden Ausnahmen sind eingestellt; deaktivieren hilft auch nicht

Bearbeitet von mysteriouscapitalist
1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gut, wenn du dich intern nicht verbinden kannst, dann kann es auch von außen nicht klappen :) ...

 

Eventuell Firewall, Virenschutz prüfen? Ob da was blockiert wird?

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Minute schrieb MarioM:

Gut, wenn du dich intern nicht verbinden kannst, dann kann es auch von außen nicht klappen :) ...

 

Eventuell Firewall, Virenschutz prüfen? Ob da was blockiert wird?

eben editiert, keine Änderung

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Okay, welche Betriebssystem hast du im Einsatz? Also von wo willst du auf welchen PC?
Ich nehme an du probierst es eh über die interne IP Adresse und nicht die öffentliche?

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Der Server läuft auf einem Laptop mit Windows 10.
Auf meinem Stand-PC, ebenfalls mit Win10 ausgestattet, läuft das Spiel.

Beide sind mit einem WLan Netzwerk verbunden.

Weder über die öffentliche noch über die interne IP Adresse lässt sich eine Verbindung erzielen.

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gut, über die öffentlich vom internen Netzwerk wirst du nicht hinkommen, außer du hast spezielle Hardware stehen oder irgendwo noch ein Service laufen.

 

Anyway, wenn du auch über die interne IP Adresse nicht hinkommst, musst du mal schauen warum das so ist. Davor macht es keinen Sinn sich über die Portweiterleitung zu unterhalten :)

 

Kannst du die Rechner pingen? Kannst du mal intern einen Portcheck machen?

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Minute schrieb MarioM:

Kannst du die Rechner pingen? Kannst du mal intern einen Portcheck machen?

Wie mache ich das am besten?

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Zum Thema Ping: https://praxistipps.chip.de/cmd-befehl-ping-test_27979

Zum Thema PortScan: https://www.chip.de/downloads/Portscanner_59218156.html

 

Wichtig dabei ist, dass der Rechner auf dem der Server läuft erreichbar ist, also das der Ping etwas zurückliefert.

Und beim PortScan sollte dann dein bekanntgegebener Port offen sein.

 

Ich hoffe das hilft dir ein wenig - wir kommen der Sache schon näher :)

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

pingvomclientzumserver.PNG.4143dbf24b3bc2961b6e0056e0c7dfb3.PNG

Hiermal das Ergebnis vom Ping Test (von Stand-PC [Client] ad Laptop [Server])

Portscanner läuft

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Okay und ich nehme an in die andere Richtung gehts auch? :) also Laptop => StandPC? :)

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Minute schrieb MarioM:

Okay und ich nehme an in die andere Richtung gehts auch? :) also Laptop => StandPC? :)

Jap, selbes Ergebnis

Glaube nicht, dass es einen Unterschied macht, aber ich sage es sicherheitshalber dazu -> der Stand-PC ist direkt mit dem LTE Router via Ethernet verbunden.

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nein das sollte normal egal sein, du kannst ihn ja pingen und damit ist er erreichbar :)

Sieht eher danach aus als hätte der Server der dort läuft ein Problem.

 

Was genau ist denn das für ein Server/Spiel wenn ich nachfragen darf?

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Es handelt sich um Impostor, ein Open Source Dedicated Server für Among Us

Bearbeitet von mysteriouscapitalist
1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Alles klar - lässt du es via Docker laufen?

Kannst du dich hinverbinden, wenn du am PC bist auf dem der Server läuft?

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nein, Docker habe ich nicht verwendet.
Ich habe gestern versucht am Stand-PC sowohl den Server als auch den Spiel-Client laufen zu lassen (zumal weder das eine noch das andere besonders Ressourcen-intensiv sind), hatte aber auch damit kein Erfolg. 

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kannst du das nochmal probieren, aber  nicht 127.0.0.1 eintragen sondern die IP Adresse des PCs auf dem der Server laufen soll?
Würde mich interessieren ob es einen Unterschied macht.

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Was soll ich versuchen - am Server PC sowohl das Spiel als auch den Server laufen zu lassen? Habe deinen Vorschlag nicht ganz verstanden

 

edit:/ habs versucht, kein Unterschied

Bearbeitet von mysteriouscapitalist
1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ja genau beides am selben PC laufen zu lassen.

Ich nehme an du hattest bei allen Versuchen die Firewall, den Virenschutz abgedreht?

 

29 minutes ago, mysteriouscapitalist said:

edit:/ habs versucht, kein Unterschied

Meinst du damit, dass du beim Starten statt 127.0.0.1 deine IP vom PC auf dem der Server läuft eingegeben hast? :)

Bearbeitet von MarioM
1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Okay, habe jetzt, glaube ich, verstanden, was du gemeint hast und habe es geschafft mich lokal mit dem Server zu verbinden - habe die Server Public IP auf die lokale Adresse (192.168.*.*) geändert, konnte sowohl vom Laptop [Server] als auch vom Stand PC [Client] eine Verbindung herstellen.

 

Mein Problem ist jedoch, dass ich über die öffentliche IP nicht in den Server reinkomme, wie in diesem Video demonstriert wird. Ab dem Timestamp ändert der Videoposter die Public IP von der lokalen auf seine öffentliche, fixe IP und kann sich dann im Laufe des Videos über den Port zum Server verbinden.

Bearbeitet von mysteriouscapitalist
1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Okay, kannst du als nächsten Schritt einfach mal 127.0.0.1 auf die IP Adresse ändern auf dem der Server läuft? Wird vermutlich eine 192.168 ... IP Adresse sein.
Und dann solltest du über das interne Netzwerk genau auf diese 192.168 verbinden können ...

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Entschuldige, ich habe mich verschrieben gehabt - konnte die Verbindung mittels 192.168-artigen Adressen aufbauen

 

Zwischenzeitlich sind die Ergebnisse vom Port Scanner da: oben - Stand PC [Client], unten - Laptor [Server]

 

Weder auf dem einen, noch auf dem anderen ist der Port 22023 offen, trotz der, meines Erachtens, richtigen Einstellungen

portscannerclient.PNG

portscannerserver.PNG

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden


×

Magenta Webmail Login

Bitte wählen Sie aus, in welches Webmail Sie sich einloggen möchten.