Zum Inhalt springen

Magenta Community

Hallo beisammen.

Seit ein paar Tagen steht bei mit o.g. Box und verrichtet bisher gute Arbeit. Ich hatte in meinem alten Netzwerk einen Raspberry laufen, der natürlich auch von außen angesurft werden konnte (DynDNS, Portweiterleitung, etc).

Bestehendes Setup wurde übernommen, die Portweiterleitung im Router hinterlegt, aber: Fehlanzeige, keine Verbindung. Auch kein Ping ist möglich, auch beim Versuch, die IP direkt anzusurfen. Lokal funktioniert alles (Also: 192.168.0.132 kann ich aufrufen, die öffentliche IP liefert mir aber den timeout).
Also kurzerhand xampp auf Windows gestartet, die Portweiterleitung auf den Rechner umgeschrieben (192.168.0.102), bisschen gewartet  und getestet: Wieder ein timeout.

Nun die Frage aller Fragen: Woran liegt das?
An den Geräten liegt es wohl eher nicht, da sie ja im alten Netzwerk funktioniert haben. Den Router habe ich auch schon neu gestartet, da tut sich auch nichts. Fehler in der config kann ich nicht erkennen.

Vielleicht kann mir ja jemand weiterhelfen :)
Danke & lg Daniel

screencapture-192-168-0-100-html-virtualserver-html-1518547480776.png

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

14 Antworten auf diese Frage

Recommended Posts

Hast du das APN auf das Business APN umgestellt:

 

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Danke schonmal!
Das hab ich jetzt gemacht und ich bekomme beim Aufruf der IP immerhin schon das Webinterface vom Router angezeigt. Das will ich ja aber gar nicht, sondern das des Pi's. Weiterleitung ist immernoch drin.
Und dass das offene Interface vom Router ein kleines Sicherheitsrisiko ist brauch ich wohl nicht sagen :/

Noch eine Idee, wie ich das genauer einstellen kann?

screencapture-192-168-0-100-html-profilesmgr-html-1518551084687.png

screencapture-192-168-0-100-html-virtualserver-html-1518551197176.png

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Beim Gäste WLAN wäre das ein Problem, sonst nicht. (Es ist eine schlechte Implementierung von NAT Loop Back)

Versuche von außen (z.B. übers Handy ohne WLAN) dann müsste der RPI auf scheinen. Wenn du nicht unbedingt HTTP braucht würde ich darauf verzichten und nur HTTPS nutzen. Zertifikat dafür hast sicherlich schon. (Wenn nicht Let's Encrypt ist eine Lösung dafür)

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Phew stimmt, von außen komm ich direkt auf den Pi. Wer geht denn bitte von sowas aus...
Port 80 lass ich offen, weil ich ne Weiterleitung auf https eingerichtet habe. Bin einfach schreibfaul, was das Protokoll angeht :D
Let's encrypt ist natürlich schon länger drinnen.

Nun aber noch ein Problem – wenn ich von außen via DynDns auf den Pi komme, von innen mit derselben Domain aber auf das WI vom Router. Und wenn ich weiterhin den Laptop im und außerhalb des WLANs verwende (auf dem PI läuft u.a. owncloud). Dann kann ich ja nicht in beiden Fällen (im & außerhalb des WLANs) meine Daten synchronisieren? Ich brauch ja dann drinnen zwingend die 192.168.0.132 und außerhalb die Dyn-Domain.

Heißt das ergo, ich muss mich für einen "Arbeitsplatz" jetzt entscheiden? Wär schon ziemlich doof... auf dem Handy ist es ja das gleiche...

Aber danke bis hierhin schonmal, allein das hat mich schon sehr viel weitergebracht!

PS: Beim Aufruf der Dyn-Domain werde ich auf "https://meineip:8443/html/index.html?origin=aHR0cHM6Ly9waXJpbmNpbmVzcy56YXB0by5xxxxx" weitergeleitet,falls das irgendwie von Interesse ist

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 21 Minuten schrieb schokomueller:

Nun aber noch ein Problem – wenn ich von außen via DynDns auf den Pi komme, von innen mit derselben Domain aber auf das WI vom Router.

Ist klar, wenn man sich genau ansieht, wie DNS funktioniert.

Du kannst dir entweder am Router die Route/Weiterleitung eintragen (sofern unterstützt) oder du hast bei dir im internen Netz einen DNS Server laufen, der das ganze auflöst. Oder du trägst das für jeden Computer in der Hosts Datei ein ...

Lg

 

Bearbeitet von MarioM
0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 17 Minuten schrieb MarioM:

Ist klar, wenn man sich genau ansieht, wie DNS funktioniert.

Ist vielleicht klar, aber die Praxis sagt bei mir etwas anderes. Mit der Fritzbox hat das alles super einfach und ohne Probleme funktioniert...

vor 18 Minuten schrieb MarioM:

Du kannst dir entweder am Router die Route/Weiterleitung eintragen

Mhm wäre eine Option. Ich finde dazu aber keine Einstellungen und Google spuckt mir bei "route" nur Router und bei "Weiterleitung" nur mehr Portweiterleitung aus.
Also falls da einer von euch für  meinen Router mehr weiß... bitte sagen.

Den Weg der hosts würde ich nur ungerne gehen, da mein Handy das ja leider nicht kann

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 17 Minuten schrieb schokomueller:
vor 39 Minuten schrieb MarioM:

Ist klar, wenn man sich genau ansieht, wie DNS funktioniert.

Ist vielleicht klar, aber die Praxis sagt bei mir etwas anderes. Mit der Fritzbox hat das alles super einfach und ohne Probleme funktioniert...

Klar, das meinte ich ja mit, es gibt Router, die das können.

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 3 Stunden schrieb schokomueller:

Also falls da einer von euch für  meinen Router mehr weiß... bitte sagen.

Leider sind eben die Standardrouter die man bekommt nicht sehr gut was solche Dinge betrifft.

Hast du nicht noch einen anderen Router den du dahinterschalten kannst?

Lg

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Naja, ich hab nur diesen für LTE-Empfang, die Fritzbox ist für DSL und in der neuen Wohnung gibt eben kein DSL. Sieht also eher mau aus leider...

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hm das ist dann blöd. Fällt mir nur mehr ein Raspi mit DNS Server ein ...

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Gibt es dazu ein statement vom tmobile support warum das nicht korrekt implementiert ist? Ich habe das selbe problem und leider so ein unbauchbares gerät zuhause.

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
22 hours ago, Fäb said:

Gibt es dazu ein statement vom tmobile support warum das nicht korrekt implementiert ist? Ich habe das selbe problem und leider so ein unbauchbares gerät zuhause.

Soweit ich weiß nicht :(

0

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Am 14.2.2018 um 12:41 schrieb MarioM:

Hm das ist dann blöd. Fällt mir nur mehr ein Raspi mit DNS Server ein ...

So habe ich das Problem mittlerweile auch behoben.
Pi-hole ist da eine recht gute Lösung, die gleichzeitig auch noch als Adblocker fungiert.

Anleitung habe ich hier gefunden:
https://www.guschlbauer.dev/private-dns-server-in-3-steps/
https://hub.docker.com/r/pihole/pihole/

2

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
2 hours ago, christian11 said:

So habe ich das Problem mittlerweile auch behoben.
Pi-hole ist da eine recht gute Lösung, die gleichzeitig auch noch als Adblocker fungiert.

Anleitung habe ich hier gefunden:
https://www.guschlbauer.dev/private-dns-server-in-3-steps/
https://hub.docker.com/r/pihole/pihole/

Sehr cool :) Danke für die Antwort ... 

1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden


  • Neue Mein Magenta App

    Die neue Mein Magenta App ist online und mit ein bisschen Glück bis 31.Mai 2020 5 Jahre Internet für Zuhause gewinnen. Einfach einloggen und am Gewinnspiel teilnehmen. https://magenta.at/magenta-app

Magenta Webmail Login

Bitte wählen Sie aus, in welches Webmail Sie sich einloggen möchten.