Jump to content

Magenta Community

  • 0

B525s-23a Port-Weiterleitung (APN und Co)


Mr.Kenny
 Share

Question

Hallo liebe Community,

das Thema "Port-Weiterleitung" ist hier durchaus ein sehr beliebtes und zuerst wird immer gern darauf verweisen den APN entsprechend zu adaptieren. Hierzu findet man ein paar Anleitungen dazu von verschiedenen Usern in diesem Forum, oder hier eine sehr offizielle Version, jedoch leicht veraltet (zumindest sieht das Interface vom letzten Post leicht anders aus als mein aktuelles). Doch die Anleitung reicht und man bekommt eine public IP-Adresse aka 78.xxx.xx.xxx (xyz.public.t-mobile.at) - erhalten via IP-Chicken Service und auch unter "Geräteinformationen" bei meinem "B525s-23a"-Gerät. Soweit so Gut!

Jetzt geht's um die Port-Weiterleitung - pfff - hier spalten sich die Geister in diesem Forum von einem Extrem ins andere. Manche behaupten es geht nur mit G3 und nicht im LTE, andere behaupten es geht gar nicht und die meisten Posts bzw. Fragen hier sind nach den Hinweis auf den APN still, somit dachte ich mir "das scheint geholfen zu haben", doch bei mir leider nicht...

"Firewall Filter Schalter" sind alle aus, Router wurde neu gestartet, PC bzw. Server ebenfalls, alle gesetzten Ports bleiben zu - auch mit diversen Diensten wie z.B. Port-Scanner bestätigt - kein Erfolg, ich komme von außen nicht in mein Eigenheim. Meine Port-Einstellungen sind wie folgt (falls sich hier ein Fehler eingeschlichen hat), Name: *beliebig* / WAN-Port: 8443-8443 / LAN-IP-Adresse: *IP zu dem PC/Server der den Port offen haben möchte* / LAN-Port: 8443-8443 / Status: An / Optionen:... (siehe ebenfalls Bild im Anhang!). Meiner Meinung nach sieht das ja ganz OK aus und sollte funktionieren. Falls nicht, lasst es mich bitte wissen ich verzweifle hier schon leicht, danke!

Zu gut der Letzt bin ich auf diese Frage gestoßen (das Gerät in Frage war hier jedoch "B529s-23a"). Der User hat, nachdem er/sie es geschafft hat eine public Adresse zu erlangen, doch schaffte es wohl auch nicht einen Port weiter zu leiten. Was mich bei einem IT-Spezialisten (Zitat aus der verlinkten Frage "ich bin IT Ing.") doch etwas Unbehagen bereitet. Ich habe mich immerhin vorab erkundigt ob Port-Weiterleitung möglich ist - siehe z.B. dieses tolle YouTube Video welches einem alle Schritte erklärt, jedoch trifft das angezeigte Interface nicht meinem "B525s-23a"-Gerät und die restlichen Schritte wurden befolgt - kann T-Mobile das jetzt schlicht weg nicht? kann das, aus welchen Gründen auch immer, meine Hardware nicht? mache ich schlicht weg was falsch?

Vielen Dank für eventuelle Antworten, ich werde weiterhin die oberhalb verlinkte Frage vom User "JonasZ" verfolgen, doch mit seinem letzten Login am 18.Sept.2018 habe ich das Gefühl er/sie hat das Handtuch geworfen - was dann die Frage in den Raum stellt, ob die angedrohte Kündigung durch nicht einhalten der vertraglich festgelegten bzw. beworbenen Funktionen tatsächlich funktioniert hat. Falls weitere Informationen benötigt werden, lasst es mich bitte wissen, danke!

PortWL.JPG

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 2

Über den Link bin ich lustigerweise noch nicht gestolpert und als ich mich so durch klicke, kam etwas was ich noch nicht ausprobiert hatte...

"Es kann in Einzelfällen passieren, dass man das Geräte komplett von Strom nehmen muss, damit es funktioniert, manchmal reicht auch ein Gerätereset aus."

Ich probiere den Spaß nun schon seit Wochen vielleicht sogar Monaten (immer wieder mal ein paar Stunden), jedoch scheint entweder etwas im Hintergrund gefixed worden zu sein, oder das min. 30 Sekunden ohne Strom war es wirklich. Nun gehen alle Port-Weiterleitungen so wie es sein sollte - zumindest von außen! Nicht ganz so wie gewohnt innerhalb des Netzes...

Das wird wohl NAT loopback sein und eine Einstellung hierzu gibt es bei meinem Gerät natürlich nicht, doch lustigerweise ging es ein paar Tage später ohne Neustart (oder bewusstem Stromausfall) wie gewollt.

In diesem Sinne war die Lösung meines Problems den physikalischen Stecker zu ziehen, 30 Sekunden warten und danach eine Woche nichts anfassen! Vielen Dank für die freundliche Hilfsbereitschaft, ich hoffe das Thema hilft dem einen oder anderem in der Zukunft mal weiter.

Link to comment
Share on other sites

  • 2

Das wusste ich nicht, somit sieht man mal wieder, dass man nie aus lernt.

Ich habe nebenbei immer "https://deineöffentlicheIP:8443/" via VPN-Nord in einem zweiten Browser und mit einem Smartphone (ohne W-Lan) probiert, leider immer mit dem gleichen Ergebnis: "Unable to connect / Firefox can’t establish a connection to the server at 78.xxx.xx.xxx:8443. / ..." (die 'x' sind natürlich die mir zugewiesene IP-Adresse)

TCPDump mit dem Befehl "sudo tcpdump -i eth0 -q '(tcp port 8443)'" gibt beim eingeben von "https://192.168.8.42:8443/" in einem Browser einen Output und bei "https://deineöffentlicheIP:8443/" erscheint keine zusätzlichen Zeilen, ich hoffe das hilft.

Link to comment
Share on other sites

  • 1

Port Scanner schon und gut, jedoch würde ich gezielter auf die beiden Port prüfen. 

Ich hatte schon Router, welche bei einem Port Scan dicht machten. 

Hat das ganze schon einmal funktioniert?

(Mit einem anderen Router/Internet Leitung)

 

Ist auf dem Server Wireshark oder ähnliches installiert, mit dem man prüfen könnte, ob die Anfrage bis zum Server kommt?

Bitte den Zugriff über eine andere Internet Leitung testen. (Smartphone & Mobilfunk würde sich anbieten)

Ist unter  https://192.168.8.42:8443/ die NextCloud oder was auch immer erreichbar?

Was für ein Server OS/Dienst ist im Einsatz?

Link to comment
Share on other sites

  • 1

Vielen Dank für deine Hilfsbereitschaft!

Ja, das hat schon mal alles funktioniert mit UPC (damals war UPC & T-Mobile noch nicht die gleiche Firma), unter "https://192.168.8.42:8443/" bzw. div. andere Ports sind alle Dienste Problemlos und wie gewohnt zu erreichen und funktionieren im Netzwerk wie eh und je. Betriebssystem meines Servers ist Debian 8.10 (Jessie). Via Smartphone-Internet (A1) komme ich zwar ins Internet, kann aber die neue IP-Adresse nicht mal pingen (was bei der öffentlichen IP mit T-Mobile ja immerhin funktioniert) und port weiterleiten ist mir unter Android nicht bekannt. Jedoch habe ich es mal mit dieser App versucht, wie zu erwarten ohne Erfolg - vielleicht liegt es auch daran, dass die von A1 nicht öffentlich ist?

Wireshark auf einem headless server einzusetzen funktioniert zwar, nur die Anwendung und auslesen der Datenmengen übersteigt mein momentanes Wissen. Wenn es hier etwas spezielles gibt, lass es mich bitte wissen und ich werde mich durch div. Tutorials durchlesen um deine Frage zu beantworten.

Kleine Notiz am Rande: nach einem Neustart hat sich das "B525s-23a"-Gerät keine public IP sondern eine 46.*** geholt, musste es dann ein weiterer Neustart her um eine public IP zu erlangen.

Link to comment
Share on other sites

  • 1

Firmware des "B525s-23a"-Geräts ist 11.230.03.01.55 und dem Webinterface nach ist dies auch die aktuellste die momentan zur Verfügung steht.

Hab ein bisschen herum gefragt und es sieht so aus als wäre ich der einzige in meinen Freundes- und Bekanntenkreis mit einem LTE-Router. Normale Router hätte ich zur genüge, doch da das "B525s-23a"-Gerät kein DMZ-Funktion besitzt kann ich nicht mal einen anderen Router dahinter stellen.

Soll ich mich mal mit der Thematik via E-Mail Support - falls so was existent ist - an T-Mobile wenden? (Wenn ich das richtig verstanden habe, ist dieses Forum ja irgenwie eine reine Community Angelegenheit)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share